Investigating System Issues
Incident Report for Socrative
Resolved
Socrative is online and this issue has now been resolved. Thank you for your patience.
Posted Sep 10, 2020 - 17:59 UTC
Investigating
Socrative is still experiencing issues in the application. Our team is working to resolve these issues. We are sorry for the impact this is having on our end-users and appreciate your patience.
Posted Sep 10, 2020 - 17:54 UTC
This incident affected: Socrative App (Core Services, Live Events, Reports).