Log in Issues
Incident Report for Socrative
Resolved
This incident has been resolved. Please contact Showbie Support if you experience any residual issues. Thank you again for your patience.
Posted Mar 14, 2021 - 13:29 UTC
Investigating
🟠Status: Investigating🟠
We are aware of an issue for some users logging into Socrative. We are looking into this and will post updates here. Thank you for your understanding.
Posted Mar 14, 2021 - 10:21 UTC
This incident affected: Socrative App (Core Services).