Investigating System Issues
Incident Report for Socrative
Resolved
Socrative is online and this issue has now been resolved, you should no longer experience issues with reports, but please let us know if you notice any on-going issues. Thank you for your patience.
Posted Feb 08, 2021 - 10:34 UTC
Investigating
Socrative is experiencing issues related to reports. We are sorry for the impact this is having on our end-users and appreciate your patience.
Posted Feb 08, 2021 - 05:55 UTC
This incident affected: Socrative App (Core Services, Live Events, Reports).