Investigating System Issues
Incident Report for Socrative
Resolved
Socrative is online and this issue has now been resolved. Thank you for your patience.
Posted Apr 16, 2021 - 11:34 UTC
Investigating
Socrative is experiencing issues in the application. Our team is working to resolve these issues. We are sorry for the impact this is having on our end-users and appreciate your patience.
Posted Apr 16, 2021 - 11:12 UTC
This incident affected: Socrative App (Core Services, Live Events, Reports).